Website connection issues.
Incident Report for PreMiD
Resolved
This incident has been resolved.
Posted May 09, 2021 - 12:11 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 09, 2021 - 12:04 CEST
Investigating
We are currently investigating this issue.
Posted May 09, 2021 - 03:28 CEST
This incident affected: Website.