Website down
Incident Report for PreMiD
Resolved
This incident has been resolved.
Posted Mar 01, 2021 - 15:50 CET
Investigating
We are currently investigating this issue.
Posted Mar 01, 2021 - 14:01 CET
This incident affected: Website.