Network issues
Incident Report for PreMiD
Resolved
This incident has been resolved.
Posted Aug 08, 2021 - 17:30 CEST
Identified
We're experiencing network issues and are trying to resolve the issue. You may experience browser checks or HTTP errors.
You don't need to report these errors as we are aware of the situation. Thank you and sorry for any inconvenience.
Posted Jul 29, 2021 - 13:38 CEST
This incident affected: Website.