API issues
Incident Report for PreMiD
Resolved
This incident has been resolved.
Posted Mar 29, 2021 - 22:08 CEST
Investigating
We are currently investigating this issue.
Posted Mar 29, 2021 - 21:35 CEST
This incident affected: API and Website.