Stable Website outage
Incident Report for PreMiD
Resolved
This incident has been resolved.
Posted Jul 20, 2020 - 20:50 CEST
Investigating
We are currently investigating an issue that is affecting our stable website.

In the meantime, please use the beta website: https://beta.premid.app
Posted Jul 20, 2020 - 04:13 CEST
This incident affected: Website.